Szerző Téma: Binary debug probléma?!  (Megtekintve 287 alkalommal)

Nem elérhető Bone1920

  • Trainee
  • *
  • Thank You
  • -Given: 14
  • -Receive: 7
  • Hozzászólások: 69
  • Segített: 7
  • Ooh Eeh Ooh Ah Aah Ting Tang Walla Walla Bing Bang
Binary debug probléma?!
« Dátum: 2019-10-08, 04:00:09 »
Helo helo sziasztok. Egy olyan furcsa problémával állok szemben amivel még asszem soha. Minap szükségem lett volna egy Debug indítóra. Lefordul szépen hiba nélkül, de amikor elindítom a klienst akkor python27_d.dll fájlra van szüksége.  ;D Ha ezt megkapja, akkor egy bizonyos memória címre hivatkozva nem indul el ugyan úgy. Esetleg valakinek lenne valami kiindulópontja? Include,lib mappát is cseréltem. Más fórumokon én sajnos nem találtam semmit sem. Ui: Tesztként néztem, van olyan magyar sf ahol pl Debugnál is python27et használ, esetleg ehhez is kaphatnék kiindulópontot? Kösz szépen előre is!  :D

Elérhető Distraught

  • Professional
  • ***
  • Thank You
  • -Given: 105
  • -Receive: 320
  • Hozzászólások: 547
  • Segített: 271
    • Facebook
Re:Binary debug probléma?!
« Válasz #1 Dátum: 2019-10-08, 10:56:53 »
Pont erre való a debug mód, hogy használd a debuggert és lásd mi törtérnik pontosan. Visual Studio propertiesnél a Debugger fül alatt a working directorynak állítsd be a kliens mappáját és nyomj a zöld start gombra, ha crashel pedig katt a breakre és láthatod a változók értékeit az adott kódrészen, meg a watch fülön végezhetsz kiértékeléseket is.

C++ programmer at Gameloft

Nem elérhető Bone1920

  • Trainee
  • *
  • Thank You
  • -Given: 14
  • -Receive: 7
  • Hozzászólások: 69
  • Segített: 7
  • Ooh Eeh Ooh Ah Aah Ting Tang Walla Walla Bing Bang
Re:Binary debug probléma?!
« Válasz #2 Dátum: 2019-10-09, 03:20:35 »
Nekem gyakorlatilag a debug indító nem indult el. Tehát Distribute módban ment lazán, probléma nélkül, csak kíváncsi voltam pár dologra. Egyébként köszi a többi infót.  :-* Témát zárom!