Szerző Téma: FreeBSD update után vulnerabilities  (Megtekintve 600 alkalommal)

Nem elérhető Power112

  • Beginner
  • Hozzászólások: 16
  • Segített: 0
FreeBSD update után vulnerabilities
« Dátum: 2021-12-11, 18:34:26 »
Sziasztok.
A következő hibát kapom Mysql telepítésnél.




vulnerabilities: Command not found.
[email protected]:/usr/ports/databases/mysql55-server # clear
[email protected]:/usr/ports/databases/mysql55-server # cd /usr/ports/databases/mysql55-server/ && make install WITH_XCHARSET=all clean
===>  mysql55-server-5.5.62_3 has known vulnerabilities:
mysql55-server-5.5.62_3 is vulnerable:
  MySQL -- multiple vulnerabilities
  CVE: CVE-2019-2513
  CVE: CVE-2019-2535
  CVE: CVE-2019-2532
  CVE: CVE-2019-2486
  CVE: CVE-2019-2531
  CVE: CVE-2019-2528
  CVE: CVE-2019-2530
  CVE: CVE-2019-2507
  CVE: CVE-2019-2481
  CVE: CVE-2019-2420
  CVE: CVE-2019-2537
  CVE: CVE-2019-2495
  CVE: CVE-2019-2494
  CVE: CVE-2019-2539
  CVE: CVE-2019-2510
  CVE: CVE-2019-2502
  CVE: CVE-2019-2536
  CVE: CVE-2019-2436
  CVE: CVE-2019-2503
  CVE: CVE-2019-2455
  CVE: CVE-2019-2434
  CVE: CVE-2019-2482
  CVE: CVE-2019-2529
  CVE: CVE-2019-2533
  CVE: CVE-2019-2534
  WWW: https://vuxml.FreeBSD.org/freebsd/d3d02d3a-2242-11e9-b95c-b499baebfeaf.html

1 problem(s) in 1 installed package(s) found.
=> Please update your ports tree and try again.
=> Note: Vulnerable ports are marked as such even if there is no update available.
=> If you wish to ignore this vulnerability rebuild with 'make DISABLE_VULNERABILITIES=yes'
*** Error code 1

Stop.
make[1]: stopped in /usr/ports/databases/mysql55-server
*** Error code 1

Stop.
make: stopped in /usr/ports/databases/mysql55-server
[email protected]:/usr/ports/databases/mysql55-server #

Hogyan lehet ezt javítani? Persze make DISABLE_VULNERABILITIES=yes nélkül?


Nem elérhető TMP4

  • Trainee
  • *
  • Hozzászólások: 90
  • Segített: 25
Re:FreeBSD update után vulnerabilities
« Válasz #1 Dátum: 2021-12-11, 22:51:20 »
Húha szerintem itt fogalom és értelmezési zavarok vannak.

Igen, valóban sebezhető a MySQL 5.5 (amúgy az 5.6 is), ezen nem kell meglepődni, egy 11 éves adatbázisról beszélünk. Én inkább azon lepődök meg hogy a mai napig elérhető a portok között, szerintem nem lesz ez már sokáig így, és majd tele leszünk olyan kérdésekkel hogy miért nem tudják feltelepíteni a MySQL55-öt, hova tűnt ;D

Te javítani a MySQL55-öt nem tudod. Azaz feltételezem nem kened vágod a MySQL forráskódját, és a sebezhetőségeket (mert azok pontos leírása nem adott, egy általános leírás elérhető csak), de ha mégis akkor nyílt forráskódú a MySQL, szabadon készíthetsz egy saját verziót az 5.5-ből.

Ezek a sebezhetőségek amúgy nem azt jelentik hogy egy mezei felhasználó vagy akár egy Metin2 "hacker" (aki igazából max cheater) majd feltöri az adatbázisodat. Rendkívül komoly szakembernek, professzionális hackernek kell lennie ahhoz hogy bármit is elérjen. Arról nem is beszélve hogy a normális szervereknél el sem érhető az adatbázis kívülről, tehát emberünknek oda kell majd szépen ballagnia ahol a szervergép fizikailag tárolva van.

Ha valóban javítani akarod, akkor sokkal egyszerűbb lenne a Metin2 szervert felkészíteni hogy képes legyen kezelni a MySQL jelenlegi verzióját, a MySQL 8.0-t. Ehhez leírás nincs, Metin2Deven pár beszélgetést tippet találsz róla amúgy.

Szerintem így ennek tudatában nyugodtan írd oda azt a DISABLE_VULNERABILITIES=yes-t (amúgy pkg-s telepítés gyorsabb és nem zaklat ilyen paraméterekkel),
ha meg nagyon félsz akkor ne lehessen kívülről elérni az adatbázist, használj phpMyadmint hozzá például.
« Utoljára szerkesztve: 2021-12-11, 23:03:47 írta TMP4 »

Nem elérhető Power112

  • Beginner
  • Hozzászólások: 16
  • Segített: 0
Re:FreeBSD update után vulnerabilities
« Válasz #2 Dátum: 2021-12-12, 14:51:15 »
Áh, értem. Köszi.